I must be missing something here...... - Page 2
Close
    
    
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
Like Tree47Likes

Thread: I must be missing something here......

  1. #11
    Senior Member elime's Avatar
    Join Date
    Jul 2010
    Location
    San Jose, CA
    Posts
    5,790
    Smitty Blackstone likes this.
    Long live the internal combustion engine!

  2. #12
    Senior Member PlacerLode's Avatar
    Join Date
    Apr 2012
    Location
    Moab - 10 days a year
    Posts
    1,634
    I have to admit thats an awesome RZR but boy would I cry the first time it rolled down the hill at SlickRock lol

    Cheap ? not so much lol

    Hell the Yamaha YXZ1000r SS I want lists for $26k and the tranny mod I need is another $3k plus labor add some led lights and whips bigger tires and poof $35k here we come !!!
    "It's Like Warm Apple Pie" - "TW-Palooza Moab 2017"

    Hidden Content

  3. #13
    Senior Member Tweaker's Avatar
    Join Date
    Dec 2015
    Location
    San Diego
    Posts
    829
    I don't get the added height. To my mind it just makes an already able machine unstable. I saw one of the YXZ1000's the other day. What a cool ride. That would be fun to do an amateur run in the Baja 500 in.
    Twin 2014 TW200's made side by side on the assembly line, Moose rear racks, Protaper Bars one with risers, DG oval pipes. rejetted carbs, 130 main jets, 2 -.020 shims on the needles and @ 2 1/2 turns on the pilot screw, #34 pilot jets, Aserbis hand guards, Shinko 241 front tires, weld on foot pegs, 14-55t sprockets, Ricochet skid plates and 90 degree fuel filters.

Page 2 of 2 FirstFirst 12

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Anyone Missing Moab Yet?
    By Fred in forum Trails, Off-road, and Adventure Riding
    Replies: 20
    Last Post: 08-30-2016, 05:22 PM
  2. Bike is Missing
    By RobG in forum Technical Help
    Replies: 101
    Last Post: 09-02-2015, 11:30 AM
  3. Another missing thread.
    By Supergoose in forum Technical Help
    Replies: 8
    Last Post: 07-29-2015, 12:16 PM
  4. what tool am i missing?
    By dutchbat in forum Technical Help
    Replies: 8
    Last Post: 06-02-2013, 12:28 PM
  5. Missing bolts?
    By TW_in_BC in forum Technical Help
    Replies: 4
    Last Post: 09-06-2010, 02:19 PM